Group Membership not shpwing all members

Have any general questions regarding the Max Power Soft AD Tool? Feel free to post them here.

Moderator: IgorMax

Post Reply
wesleyh20
Posts: 2
Joined: Fri Jan 16, 2009 6:48 am

Group Membership not shpwing all members

Post by wesleyh20 » Fri Jan 16, 2009 6:51 am

Hello,

First I must say I LOVE this product, but I am confused on something and need help. When I enumerate a group (in this case Domain Admins) it isn't showing all the members. Even if I go to a user that is not showing (in AD Reports) it shows them as a member of Domain Admins, but if you go to the Group Domain Admins (in AD Reports) there are about 5 or 6 members (on of which I just spoke about) missing. Any ideas??

-Wes

User avatar
IgorMax
Posts: 68
Joined: Tue Oct 30, 2007 7:57 pm
Location: Irvine, California
Contact:

Post by IgorMax » Mon Jan 26, 2009 7:21 am

The problem is that when AD Reports displays group members, it does not display users whose primary group is the selected group. So, when you click on a "Domain Admins" group, it shows all the members except users, whose primary group is a "Domain Admins". The reason for that is when you search for group members by "member" property AD does not return members of this group if it is a primary group for those members. It requires a little bit different approach and we are working on it right now. It will be fixed in our next release.

Igor.

User avatar
IgorMax
Posts: 68
Joined: Tue Oct 30, 2007 7:57 pm
Location: Irvine, California
Contact:

Post by IgorMax » Tue Mar 03, 2009 7:17 am

We just released a new 4.3.1.1 version of AD Reports which includes updated membership functionality. Now users can select direct members, nested members, primary group membership, load only distinguished name attribute or all attributes.

wesleyh20
Posts: 2
Joined: Fri Jan 16, 2009 6:48 am

Tried this worked but have question

Post by wesleyh20 » Fri Jun 26, 2009 8:44 am

I used the the filter option for nested group and it does work but I am a little confused. I can load a report and see the members correctly, but on the right (selected group properties) it still only shows limited number of users for domain admins. Any ideas?

User avatar
IgorMax
Posts: 68
Joined: Tue Oct 30, 2007 7:57 pm
Location: Irvine, California
Contact:

Re: Group Membership not shpwing all members

Post by IgorMax » Wed Nov 18, 2009 7:40 pm

On the right side we always show only direct members of the selected group. By the way in the last version of ADReports which is 5.3.1.2 it says
"Load Direct members"

Post Reply